Старый 27.11.2009, 17:59   #121
Новичок
 
Аватар для effetto
 
Регистрация: 26.01.2009
Адрес: Красноярск
Сообщений: 93
Вес репутации: 135
effetto - весьма и весьма положительная личностьeffetto - весьма и весьма положительная личность
По умолчанию

Проверяйте конфиг два раза, если не найдете ошибок, а сайт продолжит падать - выкладывайте здесь конфиг и параметры сервера (версии иис, асп, фреймеврка), незабыв потереть важные данные типа паролей и юзеркеев.
effetto вне форума   Ответить с цитированием
Старый 27.11.2009, 20:08   #122
Новичок
 
Регистрация: 27.11.2009
Сообщений: 4
Вес репутации: 0
pterodactilus на пути к лучшему
По умолчанию

iis7, asp 2.0, fw3.5, сайт в Emulate IE7
все без изменений, падает.
вот конфиг. вместо конф.инфы стоят точки.


<?xml version="1.0"?>
<configuration>
<effetto.Sape>
<SapeConfig UserId="мой ID" Host="мой хост.ru">
<DefaultDocuments>
<add Name="Default.aspx" />
</DefaultDocuments>
</SapeConfig>
</effetto.Sape>

<configSections>
<sectionGroup name="effetto.Sape">
<section name="SapeConfig" type="effetto.Sape.SapeConfigSection, SAPE" allowLocation="true" requirePermission="false" allowDefinition="Everywhere" />
</sectionGroup>
<sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensions SectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
<sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGro up, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
<section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptReso urceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
<sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebService sSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
<section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerial izationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>
<section name="profileService" type="System.Web.Configuration.ScriptingProfileSer viceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
<section name="authenticationService" type="System.Web.Configuration.ScriptingAuthentica tionServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
<section name="roleService" type="System.Web.Configuration.ScriptingRoleServic eSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
</sectionGroup>
</sectionGroup>
</sectionGroup>
</configSections>

<system.net>
<mailSettings>
<smtp from="administrator@хост.ru">
<network host=".." password=".." userName=".." />
</smtp>
</mailSettings>
</system.net>

<connectionStrings>
<remove name="LocalSqlServer" />
<add name="n0" connectionString=".." />
<add name="n1" connectionString=".." />
</connectionStrings>

<system.web>
<httpRuntime maxRequestLength="2097151" />
<caching>
<sqlCacheDependency enabled="true" pollTime="2000">
<databases>
<add connectionStringName="n0" name="n0"/>
</databases>
</sqlCacheDependency>
</caching>

<customErrors mode="Off"/>

<httpModules>
<add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></httpModules>

<sessionState mode="InProc" cookieless="false" timeout="30"></sessionState>
<membership userIsOnlineTimeWindow="30" >
<providers>
<clear/>
<add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, &#xA; System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
connectionStringName="LocalSqlServer" enablePasswordRetrieval="false"
enablePasswordReset="true" requiresQuestionAndAnswer="false"
applicationName="/" requiresUniqueEmail="true" passwordFormat="Hashed"
maxInvalidPasswordAttempts="5" passwordAttemptWindow="10"
minRequiredPasswordLength="5" minRequiredNonalphanumericCharacters="0"
passwordStrengthRegularExpression=""/>
</providers>
</membership>

<pages>
<controls>
<add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add tagPrefix="efe" namespace="effetto.Sape" assembly="SAPE"/>
</controls>
</pages>

<compilation debug="true" defaultLanguage="c#">
<assemblies>
<add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Web.Services, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.DirectoryServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.DirectoryServices.Protocols, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.ServiceProcess, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Web.RegularExpressions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Data.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/></assemblies>
</compilation>
<authentication mode="Forms">
<forms loginUrl="Default.aspx" protection="Validation" timeout="300"/>
</authentication>
<authorization>
<allow roles="Administrators"/>
<allow roles="Contacts"/>
</authorization>

<roleManager enabled="true" defaultProvider="YourPointRoles" cacheRolesInCookie="true" cookieName=".YourPointRoles">
<providers>
<add connectionStringName="LocalSqlServer" applicationName="YourPoint" name="YourPointRoles" type="System.Web.Security.SqlRoleProvider"/>
</providers>
</roleManager>
<webParts>
<personalization defaultProvider="aspnetdb">
<providers>
<add name="aspnetdb" type="System.Web.UI.WebControls.WebParts.SqlPerson alizationProvider" connectionStringName="LocalSqlServer" applicationName="YourPoint"/>
</providers>
</personalization>
</webParts>
<siteMap defaultProvider="XmlSiteMapProvider" enabled="true">
<providers>
<add name="XmlSiteMapProvider" description="SiteMap provider which reads in .sitemap XML files." type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.0.0, Culture=neutral, &#xA; PublicKeyToken=b03f5f7f11d50a3a" siteMapFile="web.sitemap" securityTrimmingEnabled="true"/>
</providers>
</siteMap>
<anonymousIdentification enabled="true"/>
<profile enabled="true" defaultProvider="ProfileProvider">
<providers>
<add name="ProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="LocalSqlServer" applicationName="YourPoint"/>
</providers>
<properties>
..
</properties>
</profile>

<trace enabled="false" mostRecent="true"/>

<xhtmlConformance mode="Legacy"/>
<httpHandlers>
<remove verb="*" path="*.asmx"/>
<add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFact ory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFact ory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add verb="GET,HEAD" path="ScriptResource.axd" validate="false" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></httpHandlers></system.web>

<location path="Admin">
<system.web>
<authorization>
<allow roles="Administrators"/>
</authorization>
</system.web>
</location>
<system.codedom>
<compilers>
<compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CSharp.CSharpCodeProvider,System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
<providerOption name="CompilerVersion" value="v3.5"/>
<providerOption name="WarnAsError" value="false"/></compiler>
<compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
<providerOption name="CompilerVersion" value="v3.5"/>
<providerOption name="OptionInfer" value="true"/>
<providerOption name="WarnAsError" value="false"/></compiler></compilers></system.codedom>
<system.webServer>
<httpProtocol>
<customHeaders>
<clear />
<add name="X-UA-Compatible" value="IE=EmulateIE7" />
</customHeaders>
</httpProtocol>
<validation validateIntegratedModeConfiguration="false"/>
<modules>
<remove name="ScriptModule"/>
<add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></modules>
<handlers>
<remove name="WebServiceHandlerFactory-Integrated"/>
<remove name="ScriptHandlerFactory"/>
<remove name="ScriptHandlerFactoryAppServices"/>
<remove name="ScriptResource"/>
<add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFact ory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFact ory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></handlers></system.webServer>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>
<bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/></dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>
<bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/></dependentAssembly>
</assemblyBinding>
</runtime>
<appSettings>
<add key="microsoft.visualstudio.teamsystems.aspnetdevs erver:/YourPoint" value="49388;True;4696;1;-8589669206554821808"/>
<add key="microsoft.visualstudio.teamsystems.backupinfo " value="3;web.config.backup"/>
<add key="Microsoft.VisualStudio.Enterprise.AspNetHelpe r.ChannelName" value="64ecbaf6-911d-4062-8934-d805859810a7"/>
</appSettings>
</configuration>
pterodactilus вне форума   Ответить с цитированием
Старый 30.11.2009, 10:16   #123
Новичок
 
Аватар для effetto
 
Регистрация: 26.01.2009
Адрес: Красноярск
Сообщений: 93
Вес репутации: 135
effetto - весьма и весьма положительная личностьeffetto - весьма и весьма положительная личность
По умолчанию

Секцию effetto.Sape нужно перенести под секцию configSections. Внесем изменения в инструкцию, чтобы не возникало таких недоразумений
effetto вне форума   Ответить с цитированием
Старый 30.11.2009, 11:35   #124
Новичок
 
Регистрация: 27.11.2009
Сообщений: 4
Вес репутации: 0
pterodactilus на пути к лучшему
По умолчанию

Эта рекомендация не помогла. Падает по-прежнему
pterodactilus вне форума   Ответить с цитированием
Старый 30.11.2009, 11:48   #125
Новичок
 
Аватар для effetto
 
Регистрация: 26.01.2009
Адрес: Красноярск
Сообщений: 93
Вес репутации: 135
effetto - весьма и весьма положительная личностьeffetto - весьма и весьма положительная личность
По умолчанию

Тогда конфиг верный. Идем дальше:
1) Бинарник загрузили?
2) Папка App_Data есть? есть ли на эту папку права на запись?
3) Есть ли возможность получить полное сообщение об ошибке? если есть - давайте его сюда, без него сложно понять в чем дело. Обычно хостеры предоставляют такую возможность, но как с этим обстоит дело у вашего хостера мне не известно.
4) Проверили ли все на банальные ошибки вида незакрытого тега, очепяток и тд?
effetto вне форума   Ответить с цитированием
Старый 30.11.2009, 12:11   #126
Новичок
 
Регистрация: 27.11.2009
Сообщений: 4
Вес репутации: 0
pterodactilus на пути к лучшему
По умолчанию

Цитата:
Сообщение от effetto Посмотреть сообщение
Тогда конфиг верный. Идем дальше:
1) Бинарник загрузили?
2) Папка App_Data есть? есть ли на эту папку права на запись?
3) Есть ли возможность получить полное сообщение об ошибке? если есть - давайте его сюда, без него сложно понять в чем дело. Обычно хостеры предоставляют такую возможность, но как с этим обстоит дело у вашего хостера мне не известно.
4) Проверили ли все на банальные ошибки вида незакрытого тега, очепяток и тд?
до вставки sape кода в конфиг, сайт работает стабильно и нормально. есть предложение посмотреть на проблему несколько на более серьезном уровне, потому как сайт серьезный, да и я далеко не чайник. я подозреваю, что вопрос в моем случае может затянуться, поэтому предлагаю пообщаться в контакте, например. меня можно найти здесь http://vkontakte.ru/id26250959
pterodactilus вне форума   Ответить с цитированием
Старый 30.11.2009, 12:32   #127
Новичок
 
Аватар для effetto
 
Регистрация: 26.01.2009
Адрес: Красноярск
Сообщений: 93
Вес репутации: 135
effetto - весьма и весьма положительная личностьeffetto - весьма и весьма положительная личность
По умолчанию

Я вам и предлагаю более серьезный подход, нежели "что-то не работает". Для этого нужна дополнительная информация об ошибке. Соберите эту информацию и стучитесь ко мне. Вконтакте меня найти не получится, но у меня есть ася и скайп всем известные: ася: 2O7OO6041, скайп: ph_effetto (Сегодня буду онлайн через ~3 часа).

Напоминаю, что вы всегда можете воспользоваться услугами нашей лаборатории по установке и настройке системы. Подробности здесь.
effetto вне форума   Ответить с цитированием
Старый 01.12.2009, 14:04   #128
Новичок
 
Регистрация: 29.07.2009
Сообщений: 20
Вес репутации: 0
cabrilio на пути к лучшему
По умолчанию

Цитата:
Сообщение от andqut Посмотреть сообщение
Помогите ни с того ни с сего начались такого плана ошибки:

Ошибка сервера в приложении '/'.
Процесс не может получить доступ к файлу "локальный_путь_сайта\App_Data\sape.bin", так как этот файл используется другим процессом.
Описание: Необработанное исключение при выполнении текущего веб-запроса. Изучите трассировку стека для получения дополнительных сведений о данной ошибке и о вызвавшем ее фрагменте кода.

Сведения об исключении: System.IO.IOException: Процесс не может получить доступ к файлу "локальный_путь_сайта\App_Data\sape.bin", так как этот файл используется другим процессом.

Ошибка источника:
Необработанное исключение при выполнении текущего веб-запроса. Информацию о происхождении и месте возникновения исключения можно получить, используя следующую трассировку стека исключений.


Трассировка стека:

[IOException: Процесс не может получить доступ к файлу "локальный_путь_сайта\App_Data\sape.bin", так как этот файл используется другим процессом.]
А как насчет этой ошибки, я смотрел форум, это не первый случай.
Причем как писалось ранее иногда страница грузится нормально, иногда вылетает указанная ошибка.
У меня аналогичная ситуация
cabrilio вне форума   Ответить с цитированием
Старый 01.12.2009, 14:11   #129
Новичок
 
Аватар для effetto
 
Регистрация: 26.01.2009
Адрес: Красноярск
Сообщений: 93
Вес репутации: 135
effetto - весьма и весьма положительная личностьeffetto - весьма и весьма положительная личность
По умолчанию

Движек - последняя пятничная бета или стандартный из системы, или другой?

Добавлено через 2 минуты
Дело в том, что в последнем релизе мы этот эксепшен прикрыли.

Добавлено через 1 минуту
Последняя версия

Последний раз редактировалось effetto; 01.12.2009 в 14:11. Причина: Добавлено сообщение
effetto вне форума   Ответить с цитированием
Старый 02.12.2009, 01:27   #130
Новичок
 
Регистрация: 29.07.2009
Сообщений: 20
Вес репутации: 0
cabrilio на пути к лучшему
По умолчанию

Цитата:
Сообщение от effetto Посмотреть сообщение
Движек - последняя пятничная бета или стандартный из системы, или другой?

Добавлено через 2 минуты
Дело в том, что в последнем релизе мы этот эксепшен прикрыли.
Не работает ни стандартный из системы, ни новая версия бета

Ошибка осталась. (декларативный вызов)

P.S. Есть другой сайт на Windows-хостинге, там SAPE на ASP.net отлично работает
cabrilio вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
НОВЫЙ ГОД!!!!!!!!!!!! Globalzru Курилка 34 01.01.2009 20:39
новый хостинг awe Ошибки при работе с системой 8 10.10.2008 18:30
Новый акк goglin Вопросы по работе системы 18 04.10.2008 15:40
Новый вид анкоров? Chervechok Курилка 9 17.09.2008 08:21
новый сайт.. brucekiev Вопросы от новичков 8 21.12.2007 18:26


Часовой пояс GMT +3, время: 04:48.