Старый 16.08.2007, 05:32   #1
Специалист
 
Регистрация: 04.06.2007
Сообщений: 244
Вес репутации: 0
koro не любят в этих краях
По умолчанию Вопрос по кодировке

Здравствуйте. Такой вопрос. Есть сайт на котором страницы в основном написаны руками на html т.е. не CMS и есть раздел сайта (галерея куперман) Проблема возникла при добавлении раздела с галереей в систему. Кодировка у кода сапе по умолчанию windows-1251 (не указано явно в коде) и на страницах html код отображается корректно. Помучавшись я установил код и на куперман, но там явно нужно прописывать кодировку utf-8. Обновив линкс дб порадовался что в галерее все корректно отображается случайно глянул на html часть и вы наверно поняли, там все в кодировке utf-8 в общем линкс дб заполнился ссылками только в кодировке которая указана явно. Я попробовал поекспериментировать (прописывая для куперман utf-8 а в html коде windows-1251 и обновляя links.db), но ничего у меня не вышло, кодировка работала или одна или другая - вместе - никак. Есть какой то выход? Можно как то создать два links.db для различных коlировок? Или есть какое то еще решение?
koro вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Публикация ссылок на сайте в кодировке UTF-8 LIN Вопросы по работе системы 13 12.05.2008 18:22
Вопрос по неправильно кодировке Rigor Ошибки при работе с системой 7 30.04.2008 15:07
Сылки в разной кодировке Ramzes Вопросы по работе системы 13 22.01.2008 21:19
Все ссылки выводятся в левой кодировке sergei76 Ошибки при работе с системой 1 03.12.2007 11:12
глюк в кодировке ссылок seocat Ошибки при работе с системой 5 28.10.2007 13:04


Часовой пояс GMT +3, время: 20:09.