Старый 17.06.2008, 23:58   #31
Администратор
 
Аватар для Ank
 
Регистрация: 05.02.2007
Сообщений: 18,407
Вес репутации: 671
Ank - прекрасное будущееAnk - прекрасное будущееAnk - прекрасное будущееAnk - прекрасное будущееAnk - прекрасное будущееAnk - прекрасное будущееAnk - прекрасное будущееAnk - прекрасное будущееAnk - прекрасное будущееAnk - прекрасное будущееAnk - прекрасное будущее
По умолчанию

а..

$o['verbose'] = true;
$o['host'] = 'http://www.site.ru';
$sape_context = new SAPE_context($o);
$sape = new SAPE_client($o);

тогда вот так переделайте.
И расскажите каким методом выводите контекст, их 2.
И еще интересно где именно все таки стоит код, при таком расположении он должен быть между тегами </head> и <body>, что плохо стыкуется с простыми.. хотя при $tpl->set('{links} может и будет работать...
сейчас не помню точно, но для контекста есть еще вывод отладочной инфы..
кстати. В исходном коде в состоянии $o['verbose'] = false; видны теги сапе_индекс?
ну и совсем кстати.
Может всетаки разнести работающий просто код и неработающий контекст? им вовсе необязательно вместе жить.
Ну и совсем кстати.
Вы говорите что на таом же движке у Вас есть работающий проект и там с контектом все в порядке - посмотрите туда..
Ank вне форума   Ответить с цитированием
Старый 18.06.2008, 02:11   #32
Эксперт
 
Регистрация: 13.07.2007
Сообщений: 1,292
Вес репутации: 190
Danila - очень-очень хороший человекDanila - очень-очень хороший человекDanila - очень-очень хороший человекDanila - очень-очень хороший человекDanila - очень-очень хороший человек
По умолчанию

Цитата:
Сообщение от Ank Посмотреть сообщение
Вы говорите что на таом же движке у Вас есть работающий проект и там с контектом все в порядке - посмотрите туда..
Я прям оттуда и копировал, только менял пар-р:
$o['host'] = 'http://www.site.ru';
на
$o['host'] = 'http://www.drugoy_site.ru';

Вобщем, что сделал:

Цитата:
if (!defined('_SAPE_USER')){
define('_SAPE_USER', '6c3**97');
}
require_once($_SERVER['DOCUMENT_ROOT'].'/'._SAPE_USER.'/sape.php');
$o['host'] = 'http://www.winblog.ru';
$sape_context = new SAPE_context($o);
unset($o);
ob_start(array(&$sape_context,'replace_in_page'));


if (!defined('_SAPE_USER')){
define('_SAPE_USER', '6c32233a88c9af108d4850e27c292d97');
}
require_once($_SERVER['DOCUMENT_ROOT'].'/'._SAPE_USER.'/sape.php');
$o['host'] = 'http://www.winblog.ru';
$sape = new SAPE_client($o);
$tpl->set('{links}', $sape->return_links(2));
$tpl->set('{links1}', $sape->return_links(2));
$tpl->set('{links2}', $sape->return_links());
Вроде ссылки стали показываться, количество контекстных страниц увеличилось в 2 раза до 1900, words.db создается нормально. Но! перестали работать обычные ссылки

Добавлено через 25 минут
Так... Вроде получилось. Вставил:

Цитата:
if (!defined('_SAPE_USER')){
define('_SAPE_USER', '6c32xxxxxxxxxxxxxxxxxxxxxxxxxxxxd97');
}
require_once($_SERVER['DOCUMENT_ROOT'].'/'._SAPE_USER.'/sape.php');
$o['host'] = 'http://www.site.ru';
$sape_context = new SAPE_context($o);
unset($o);
ob_start(array(&$sape_context,'replace_in_page'));


if (!defined('_SAPE_USER')){
define('_SAPE_USER', '6c32xxxxxxxxxxxxxxxxxxxxxxxxxx92d97');
}
require_once($_SERVER['DOCUMENT_ROOT'].'/'._SAPE_USER.'/sape.php');
$o['host'] = 'http://www.site.ru';
$sape = new SAPE_client($o);
$tpl->set('{links}', $sape->return_links(2));
$tpl->set('{links1}', $sape->return_links(2));
$tpl->set('{links2}', $sape->return_links());
Удалил words.db links.db, очистил кеш сайта и браузера, отключил gzip. Пока вроде работает. Ждем роботов...

Последний раз редактировалось Danila; 18.06.2008 в 02:37. Причина: Добавлено сообщение
Danila вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Пропали ссылки! raanani Ошибки при работе с системой 9 28.04.2008 23:00
Я ВМ. Пропали ссылки Dima1151 Вопросы по работе системы 5 02.12.2007 21:21
пропали ссылки sca Вопросы по работе системы 4 31.10.2007 18:34
ПРопали все ссылки webscaner Вопросы по работе системы 7 19.08.2007 17:39
Пропали ссылки greyspb Ошибки при работе с системой 8 24.01.2007 14:52


Часовой пояс GMT +3, время: 09:18.