Старый 02.07.2007, 12:04   #1
Новичок
 
Регистрация: 02.07.2007
Сообщений: 42
Вес репутации: 0
IMHO может только надеяться на улучшение
По умолчанию Вопросики

успешно поставил скрипт, пошли первые линки. обнаружил, что все они неверно отображаются. Одни вопросики вместо русского текста. На странице стоит утф. есть решение проблемы?
ИД=35048
IMHO вне форума   Ответить с цитированием
Старый 02.07.2007, 12:55   #2
Новичок
 
Регистрация: 21.03.2007
Сообщений: 77
Вес репутации: 178
Burzuy на пути к лучшему
По умолчанию

Если на Вашем сайте используется кодировка русских букв, отличная от windows-1251, то необходимо в коде вывода ссылок (который вы вставляете на каждую страницу сайта) строку:

$sape = new SAPE_client();

изменить на:

$o['charset'] = 'UTF-8';
$sape = new SAPE_client($o);
unset($o);
Burzuy вне форума   Ответить с цитированием
Старый 02.07.2007, 13:14   #3
Новичок
 
Регистрация: 02.07.2007
Сообщений: 42
Вес репутации: 0
IMHO может только надеяться на улучшение
По умолчанию

Код изменил. вопросики остались.
IMHO вне форума   Ответить с цитированием
Старый 02.07.2007, 16:52   #4
Новичок
 
Регистрация: 02.07.2007
Сообщений: 42
Вес репутации: 0
IMHO может только надеяться на улучшение
По умолчанию

всё наладилось. спасибки за совет.
IMHO вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Часовой пояс GMT +3, время: 14:28.